31 lines
670 B
Bash
31 lines
670 B
Bash
# Maintainer: Nicholas Novak <nicholasmnovak@gmail.com>
|
|
|
|
pkgname=assign-notify
|
|
pkgver=r5.29dcc86
|
|
pkgrel=1
|
|
pkgdesc="Assignment Notifier CLI"
|
|
arch=('any')
|
|
makedepends=('git')
|
|
provides=('assign-notify')
|
|
depends=('go')
|
|
url="https://gitlab.nicholasnovak.io/nnovak/assign-notify"
|
|
source=(
|
|
"assign-notify::git+https://git.nicholasnovak.io/nnovak/assign-notify.git"
|
|
)
|
|
md5sums=('SKIP')
|
|
|
|
pkgver() {
|
|
cd "$srcdir/assign-notify"
|
|
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
|
}
|
|
|
|
build() {
|
|
cd "$srcdir/assign-notify"
|
|
go build .
|
|
}
|
|
|
|
package() {
|
|
# Install the binary
|
|
install -vDm 755 "$srcdir/assign-notify/$pkgname" "$pkgdir/usr/bin/$pkgname"
|
|
}
|